De Linux-kernel blijkt al sinds 2013 kwetsbaar te zijn. Doordat het een fout bevat kunnen hackers apparaten met wifi-chips van Realtek laten crashen. In sommige gevallen is het zelfs mogelijk de apparaten over te nemen.

De kwetsbaarheid zit in de RTLWIFI driver die wordt gebruikt om Realtek wifi kaarten in Linux apparaten aan te sturen.

Nico Waisman, Principal security engineer van GitHub heeft tegen Ars Technica verklaard dat de fout misbruikt kan worden als het getroffen apparaat in de buurt is van een malafide apparaat. Als wifi aan staat, is er geen enkele interactie van de eindgebruiker nodig om de fout te misbruiken.

Deze kwetsbaarheid kan vervolgens worden gebruikt door grote hoeveelheden data te schrijven of op te roepen van of naar de buffer. Doordat dit de buffer teveel wordt, ontstaat er een buffer overflow.

Waisman stelt dat hackers in ieder geval een besturingssysteem kunnen laten crashen, maar mogelijk kunnen ze ook de volledige controle van een apparaat overnemen. De fout maakt een groot aantal Linux-kernels kwetsbaar, te weten alle Linux-kernels sinds versie 3.10.1 uit 2013. Wel moet het apparaat een Realtek chip bevatten, omdat de kwetsbaarheid daar in zit.

Volgens Waisman is de kwetsbaarheid zeer gevaarlijk, ook al zijn er nog geen proof-of-concept aanvallen opgesteld. Omdat er nog niet daadwerkelijke malafide code is uitgevoerd op een kwetsbaar systeem is nog niet duidelijk hoe gevaarlijk de fout precies is. Waisman zegt hier wel aan te werken.

Er wordt ondertussen wel een oplossing voor de fout ontwikkeld, onder de code CVE-2019-17666. Linux ontwikkelaars stelden vorige week woensdag een oplossing voor die naar alle waarschijnlijkheid snel onderdeel zal worden van de kernel.

Verwacht wordt dat in de komende dagen of weken de oplossing wordt uitgerold naar verschillende Linux distributies.